Wednesday, February 23, 2011

Nokia Frustration, cont'd

OK. We've been struggling for several days to install a functional version of one or another of the Nokia Suites: Ovi or PC on Windows XP (Service pack 3).

They grind and grind and nothing happens.

So finally we nuke the session, reboot, nuke the software, and try a different iteration.

Then today it occured to me: maybe it is trying to phone home and my (excellent) firewall is not allowing this?

So tonight we try again: delete all traces of Nokia anything, reboot, and restart installation, this time of Ovi Suite, and monitor the firewall log:

+ Ovi Suite itself progresses (slowly) without any firewall activity. But then complains Minimal memory 256 MB . So shut down, adjust memory, reboot, restart the installation.

Yes, indeedy. It is trying to phone home. The firewall reports (dmesg):

[12735.781008] ABORTED IN=wlan0 OUT= MAC=00:24:d2:2b:e1:52:94:44:52:78:f0:28:08:00 SRC= DST= LEN=40 TOS=0x00 PREC=0x00 TTL=47 ID=0 DF PROTO=TCP SPT=80 DPT=2398 SEQ=3165126420 ACK=0 WINDOW=0 RES=0x00 RST URGP=0

To which I respond:
     P1630:~ # whois receive:
netname:        TROLLTECH-NET1-OSL-NO

So TrollTech (QT) is trying to read me because OVI is built on QT. But my firewall is blocking this.

Is this why the app won't install? Why didn't they tell me beforehand?

But before I open the firewall port I want to try all other available options:

OVI Suite has installed successfully, it wants me to do all kinds of things, but gracefully gives me the option of "doing this later".

OK, nevermind, continue. Reboot WinXP, and continue to try to install the phone, this time monitoring the firewall.

First, Ovi asks me to plug in the device. I do.

dmesg reports discovery
    [14282.120826] usb 1-3: Product: N8-00

but also reports a fault:
    [14282.124194] usb 1-3: bad CDC descriptors
    [14282.125721] cdc_phonet: probe of 1-3:1.14 failed with error -22

This is troublesome (probe failed) but Windows XP recognizes the phone in the tray.
    Found new hardware... etc.
Ovi says Please wait while USB drivers are installed on your computer but then freezes.

Firewall log does not show any blocking. But now Ovi is completely frozen. Fortunately WinXP is not, so we shutdown and reboot.

Once again, start up Ovi Suite. No firewall messages, but the above cited bad CDC descriptors complaint. But Ovi never restarts.

OK, shutdown, reboot.

Ooops, black screen of death. Once again, shut down. Period.

Start again.

OK, this time we get a warning about WinXP not having started correctly, we choose Start Normally and up it comes.

Now the test: wait for all the disk thrashing to stop and then try to start Ovi. The thrashing goes on for about one minute (timed).

Plug in the phone. dmesg reports

[16009.828303] usb 1-3: bad CDC descriptors
[16009.830473] cdc_phonet: probe of 1-3:1.14 failed with error -22

and indeed Ovi fails to see the phone.

So there is something in the CDC descriptors that is preventing Ovi (or, I'll bet I get the same result tomorrow from PC Suite) from finding the phone.

Time for bed.

No comments: