Saturday, February 4, 2012

GnuCash 2.4.9 Workaround

The upgrade of openSUSE to version 12.1 results in an upgrade of the guile library from version 1.8 to version 2.0.
Unfortunately GnuCash (versions 2.4.7 and 2.4.9)  still depend on guile 1.8. As a result GnuCash crashes on start with 
     ERROR: In procedure debug-options-interface: Unknown option name: maxdepth
for the gory details.
Fortunately, there is a workaround until the openSUSE folks sort this out.
The workaround is to use YaST (yast2 sw_single) to DELETE guile 2.0. This will result in an offer to roll back gnucash to version 2.4.7 and to roll back guile to version 1.8.
Which is fine by me.

No comments: